Úvod PS Cvičenie 2: Základná konfigurácia zariadení

Cvičenie 2: Základná konfigurácia zariadení

6249
0

Na nasledujúcej topológií realizujte základnú konfiguráciu smerovača a zabezpečte funkčnosť komunikácie medzi PC1 a R1.

Topológia:

  1. Konfigurácia názvu zariadenia a hesiel:

Na zmenu názvu zariadenia sa používa príkaz hostname. Ďalej je potrebné zabezpečiť prístup na zariadenia, ktorý je možné realizovať nasledujúcimi spôsobmi:

  • Heslo do privilegovaného režimu (nešifrované/šifrované)
  • Heslo do konzoly
  • Heslo pre virtuálne terminály
Router(config)#hostname R1
R1(config)#enable password class
R1(config)#enable secret cisco
R1(config)#service password-encryption
R1(config)#line console 0
R1(config-line)#password konzola
R1(config-line)#login
R1(config)#line vty 0 15
R1(config-line)#password telnet
R1(config-line)#login
Poznámka:
Hesla sú v bežiacej konfigurácii uložené nezašifrovane. Tieto heslá je možné zašifrovať jednoduchou šifrou (ľahko prelomiteľnou) príkazom service password-encryption.
Poznámka:
Príkaz login slúži na vyžiadanie hesla od používateľa (pri konfigurácii vty je tento príkaz štandardne zapnutý).
  1. Konfigurácia rozhraní:

Do režimu konfigurácie rozhrania sa dostaneme príkazom interface. V rámci tohto režimu konfigurujeme popis rozhrania príkazom description, IP adresy príkazom ip address. Rozhrania je potrebné zapnúť príkazom no shutdown, keďže sú štandardne na smerovači vypnuté..

R1(config)#interface fastethernet 0/0
R1(config-if)#description Prepoj s PC1
R1(config-if)#ip address 192.168.10.1 255.255.255.0
R1(config-if)#no shutdown
Poznámka:
Na sériovom rozhraní konfigurujeme aj clock rate – na DCE strane (pomocou príkazu show controllers serial0/0/0 zistíme o akú stranu ide).

 

R1(config-if)#clock rate 64000
Poznámka:
Informácie o rozhraniach (stav, ip adresa …) zobrazíme pomocou príkazu show ip interface brief.

 

R1#show ip interface brief
  1. Konfigurácia správy dňa:

Zobrazuje správu po pripojení na zariadenie. Použitý znak v našom prípade ‚*‘ slúži na ohraničenie správy, ktorá bude vypísaná. Nesmie sa vyskytovať v tele správy!!!

R1(config)#banner motd *Neautorizovaným používateľom prístup zakázaný!!!*

 

  1. Konfigurácia SSH:

Pri konfigurácii SSH potrebujeme vytvoriť lokálnu databázu, vzhľadom ku ktorej sa budeme autentifikovať. Ďalej nakonfigurujeme hostname a doménové meno príkazom ip domain-name, z ktorých sa bude generovať kľúč na šifrovanie. Následne vygenerujeme kľúč príkazom crypto key generate rsa (veľkosť určíme). Na terminál potom povolíme prihlasovanie len cez SSH pomocou príkazu transport input ssh a na prihlásenie použijeme lokálnu databázu príkazom login local.

R1(config)#username student password cvicenie2
R1(config)#ip domain-name cnl.sk
R1(config)#crypto key generate rsa
R1(config)#line vty 0 4
R1(config-line)#login local
R1(config-line)#transport input ssh

 

  1. Uloženie/odstránenie konfigurácie:

Bežiacu konfiguráciu môžeme uložiť:

  • Do štartovace konfigurácie (NVRAM)
  • Na tftp (server)
Pre odstránenie štartovacej konfigurácie používame erase startup-config.
R1#copy running-config startup-config
R1#copy running-config tftp
R1#erase startup-config
Poznámka:
Bežiacu konfiguráciu môžeme zobraziť pomocou príkazu show running-config.

 

R1#show running-config

 

  1. Doplňujúce príkazy:

Na vypnutie automatického vyhodnotenia nerozpoznaného príkazu na lokálny hostiteľský názov použijeme príkaz no ip domain-lookup. Pre synchrónne zapisovanie do konzoly je potrebné zadať príkaz logging synchronous. Príkaz exec-timeout určí po akom čase nečinnosti bude používateľ odhlásený z danej prístupovej linky. Bezpečnosť je zas možné zvýšiť príkazom na definovanie minimálneho hesla a to security password min-length. Na zabránenie útoku tvrdou silou slúži zas príkaz login block-for, ktorý určí ako dlho bude zablokovaný prístup na prihlásenie, v prípade ak došlo k určenému počtu neúspešných prihlásení v rámci definovaného intervalu.

R1(config)#no ip domain-lookup
R1(config)# security password min-length 8
R1(config)# login block-for 120 attempts 3 within 60
R1(config)# line console 0
R1(config-line)#logging synchronous
R1(config-line)# exec-timeout 5 30

 

  1. Ping a traceroute
  • ping urobí kontrolu konektivity na tretej vrstve s cieľovým zariadením s IP adresou w.x.y.z
  • traceroute vypíše cestu (zoznam smerovačov) k cieľovému zariadeniu s IP adresou w.x.y.z
R1#ping w.x.y.z
R1#traceroute w.x.y.z
Poznámka:
všetky príkazy privilegovaného módu vieme zadať aj z globálneho konfiguračného alebo vyšších módov pridaním kľúčového slova do pred príkaz.
  1. Príkazy zadávane v CMD na PC
    • 1. Zobrazenie sieťových nastavení:
C:\>ipconfig

C:\>ipconfig /all

 

    • 2. Testovanie konektivity:
C:\>ping w.x.y.z

C:\>tracert w.x.y.z

 

  1. Priradenie Sieťových nastavení na koncové zariadenie:

Open Network and Sharing Centre -> Ethernet -> Change adapter settings -> Klik pravým tlačidlom na sieťovú kartu -> Properties -> Protocol TCP/IPv4 (Internet Protocol Version 4) -> Properties

Na tomto mieste treba zmeniť nastavenia IPv4 adresy, masky a brány.

Poznámka:

Príkazom nslookup z príkazového riadku je možné zistiť IP adresu na základe zadaného doménového názvu.

C:\>nslookup netacad.com

Ukážka základnej konfigurácie na smerovači od spoločnosti MikroTik

Na nasledujúcej topológií realizujte základnú konfiguráciu smerovača a zabezpečte funkčnosť komunikácie medzi PC-1 a MikroTik smerovačom.

Topológia:

1. Konfigurácia názvu zariadenia a hesla

Zmeňte názov smerovača na Router1. Následne je potrebné zmeniť heslo do príkazového riadku smerovača, keďže MikroTik nemá definované žiadne predvolené heslo. Nastavenie prihlasovacieho mena a hesla býva zvyčajne automaticky vyžiadané pri prvom spustení smerovača, avšak je ho možné zmeniť aj príkazom.

/system identity set name=Router1 # zmena názvu zariadenia

/password # zmena hesla

2. Konfigurácia správy dňa a reálneho času

Správu, ktorá je zobrazená po pripojení na zariadenie, je možné nastaviť pomocou príkazu. Od zapnutia zariadenia je na smerovači MikroTik nastavený aktuálny reálny čas, avšak je možné ho pozmeniť.

/system note set note=[text] # nastavenie správy dňa

/system clock # nastavenie času

3. Konfigurácia komunikácie medzi PC-1 a MikroTik smerovačom

Nastavte základne sieťové nastavenia počítača ako sú IP adresa a brána podľa priloženej topológie. Vzhľadom k topológii siete, nastavte na rozhranie ether1 príslušnú IP adresu. Vytvorenú komunikáciu overte.

/ip address add address=192.168.1.254/24 interface=ether1 # pridanie IP adresy na rozhranie

4. Konfigurácia SSH pripojenia

Existujú rôzne metódy vytvorenia spojenia SSH, ako napríklad pomocou podmenu /system ssh vďaka ktorému dokážeme vytvoriť priame SSH spojenie na zvolenú IP adresu. Úlohou bude vytvorenie používateľa s menom user1, heslom heslo123 s priradením do existujúcej skupiny read a následné pripojenie pomocou protokolu SSH. Konfiguráciu je možné vykonať dvoma spôsobmi a to pomocou grafického rozhrania a príkazového riadku.

/user add name=user1 group=read password=heslo123 # vytvorenie používateľa, priradenie do určitej skupiny a definovanie hesla

Konfigurácia pomocou grafického rozhrania

Pre prístup ku grafickému rozhraniu je potrebné zadať IP adresu smerovača do webového prehliadača. Následne sa zobrazí prihlasovacie okno kde je potrebné sa prihlásiť ako admin s plnými právami. Základná konfigurácia MikroTik smerovača sa nachádza v podmenu System. Ako vidíme na obrázku 4.3 zmenu názvu zariadenia je možné vykonať v záložke Identity.

Obr. 4.3: Nastavenie názvu smerovača

Konfigurácia hesla je zobrazená na obrázku 4.4, túto možnosť nájdeme pod záložkou Password.

Obr. 4.4: Nastavenie hesla smerovača

Nastavenie hodín je možné vykonať v podmenu Clock, ako vidíme na obrázku 4.5.

Obr. 4.5: Nastavenie hodín smerovača

Definovať správu dňa je možné v záložke Note, ako je zobrazené na obrázku 4.6.

Obr. 4.6: Nastavenie správy dňa smerovača

Ak chceme pridať IP adresu na rozhranie smerovača môžeme to uskutočniť v podmenu IP->Adresses. Po rozkliknutí záložiek sa zobrazí list adries kde môžeme pomocou tlačidla Add zobraziť okno v ktorom sa daná konfigurácia vykoná. Pridanie IP adresy na rozhranie je zobrazené na obrázku 4.7.

Obr. 4.7: Nastavenie IP adresy na rozhranie smerovača

Pre vytvorenie nového používateľa je potrebné prejsť do záložky WebFig -> System -> Users. Ako vidíme na obrázku 4.8 následne pomocou tlačidla Add New vytvoríme nového používateľa s určitým menom a heslom. Po vytvorení používateľa otestujeme SSH spojenie pomocou nástroja PuTTY, kde zadáme IP adresu smerovača. Smerovač automaticky po nadviazaní spojenia vyžaduje prihlasovacie údaje používateľa.

Obr. 4.8: Vytvorenie nového používateľa pomocou grafického rozhrania