Úvod PS Cvičenie 6: Smerovanie dát medzi VLAN

Cvičenie 6: Smerovanie dát medzi VLAN

4188
0

Topológia:

Prepojte sa a pomenujte zariadenia podľa obrázka. PC dajte poslednú použiteľnú adresu a smerovaču prvú použiteľnú adresu.

Princíp smerovača na paličke spočíva v tom, že smerovač zabezpečuje smerovanie dát medzi VLAN využitím subrozhraní. Postup konfigurácie je nasledovný.

  1. Vytvorenie VLAN a priradenie portov do príslušnej VLAN:
SW(config)#vlan 10
SW(config-vlan)#name VLAN10
SW(config)#int fa0/23
SW(config-if)#switchport mode access
SW(config-if)#switchport access vlan 10
SW(config)#vlan 20
SW(config-vlan)#name VLAN20
SW(config)#int fa0/24
SW(config-if)#switchport mode access
SW(config-if)#switchport access vlan 20

 

  1. Konfigurácia Trunk rozhrania:
SW(config)#int fa0/1
SW(config-if)#switchport trunk encapsulation dot1q -len na L3 prepínači
SW(config-if)#switchport mode trunk
SW(config-if)#switchport trunk allowed vlan 10,20

 

  1. Konfigurácia subrozhraní na smerovači:

Ak chceme zabezpečiť komunikáciu medzi zariadeniami v rôznych VLAN, tak potrebujeme na pomoc L3 zariadenie, ktorým môže byť smerovač alebo L3 prepínač. Pre tento účel využijeme smerovač (Router-on-a-Stick). Konfiguračne postupujeme tak, že na smerovači vytvoríme z jedného fyzického rozhrania viaceré logické (subrozhrania) a každému subrozhraniu povieme akú VLAN bude spracovávať.

R(config)#int fa0/0.10
R(config-subif)#description brána pre VLAN10
R(config-subif)#encapsulation dot1Q 10
R(config-subif)#ip add 192.168.1.1 255.255.255.0
R(config-subif)#int fa0/0.20
R(config-subif)#description brána pre VLAN20
R(config-subif)#encapsulation dot1Q 20
R(config-subif)#ip add 192.168.2.1 255.255.255.0
R(config-subif)#int fa0/0
R(config-if)#no shutdown

 

Poznámka:
Pre zapuzdrenie neznačených dát použijeme príkaz:

R(config-subif)#encapsulation dot1Q 20 native

 

  1. Smerovanie dát medzi VLAN za použitia L3 prepínača:

Smerovač môžeme nahradiť prepínačom pracujúcom na tretej vrstve OSI modelu. Smerovanie je možné následne zabezpečiť využitím virtuálnych rozhraní (SVI) alebo využitím smerovaných rozhraní.

  1. Smerovanie využitím SVI:

Na prepínači vytvoríme virtuálne rozhranie pre každú VLAN, ktorú chceme smerovať. Rozhranie, ku ktorému pripojíme náš prepínač SW bude v móde trunk. Na prepínači je potrebné ešte zapnúť smerovanie príkazom ip routing.

L3_SW(config)# ip routing
L3_SW (config)# interface vlan 10
L3_SW (config-if)# description SVI pre sieť 192.168.1.0/24
L3_SW (config-if)# ip address 192.168.1.1 255.255.255.0
L3_SW (config-if)# no shutdown
L3_SW (config)# int vlan 20
L3_SW (config-if)# description SVI pre 192.168.2.0/24
L3_SW (config-if)# ip address 192.168.2.1 255.255.255.0
L3_SW (config-if)# no shutdown
  1. Smerovanie využitím smerovaných rozhraní:

Smerovaný port sa správa ako rozhranie na smerovači, ktoré na prepínači aktivujeme príkazom no switchport. Nie je z neho ale možné vytvárať subrozhrania. Pripojenie L2 prepínača k L3 prepínaču sa realizuje access rozhraniami na strane L2 a smerovanými rozhraniami na strane L3 prepínača.

L3_SW (config)# interface FastEthernet0/1
L3_SW (config-if)# description smerované rozhranie pre VLAN10
L3_SW (config-if)# no switchport
L3_SW (config-if)# ip address 192.168.1.1 255.255.255.0
L3_SW (config-if)# no shutdown