Úvod PS Cvičenie 7: Dynamické prideľovanie sieťových nastavení a protokol HSRP

Cvičenie 7: Dynamické prideľovanie sieťových nastavení a protokol HSRP

3934
0

Topológia:

Smerovačom prideľte prvé použiteľné adresy z daných podsietí. Medzi R1-R2 dajte R1 prvú a R2 druhú použiteľnú adresu.

  1. DHCPv4:

DHCP je protokol, ktorý slúži na prideľovanie sieťových nastavení ako IP adresa, maska, default-gateway, DNS a pod. Smerovač sa stáva DHCP serverom, ak na ňom nakonfigurujeme DHCP pool. IP adresy, ktoré sú staticky nakonfigurované v sieti – napr. tlačiareň/server je potrebné vyradiť z DHCP poolu.

R1(config)#ip dhcp excluded-address 192.168.10.1
R1(config)#ip dhcp pool LAN10
R1(dhcp-config)#default-router 192.168.10.1
R1(dhcp-config)#network 192.168.10.0 255.255.255.0
R1(dhcp-config)#dns-server 8.8.8.8
R1(dhcp-config)#domain-name cnl.sk

Z pohľadu koncového zariadenie je z príkazového riadka potrebné zadať príkazy:

C:\>ipconfig /release
C:\>ipconfig /renew
Poznámka:
Konfiguráciu overujeme príkazom show ip dhcp pool a mapovanie pridelených adries príkazom show ip dhcp binding.
Poznámka: Relay agent
Ak smerovač nie je priamo DHCP serverom, tak ho konfigurujeme ako relay agenta, ktorý DHCP požiadavku unicastovo prepošle na DHCP server. Konfigurácia na rozhraní smerujúcom do LAN.
R1(config)#interface fa0/0
R1(config-if)#ip helper-address 192.168.20.1
R1(config-if)#ipv6 dhcp relay destination 

Poznámka:
Ak je samotný smerovač DHCP klientom, tak na rozhraní zadáme príkaz ip/ipv6 address dhcp alebo ipv6 address autoconfig.

  1. DHCPv6:
  • Pre IPv6 použite adresy:
    • 2001:db8:0:1::/64 – pre sieť kde je PC1, na smerovač dajte prvú použiteľnú adresu
    • 2001:db8:0:abcd::/64 – na prepoj R1-R2, na R1 dajte prvú použiteľnú a na R2 druhú adresu
    • 2001:db8:0:2::/64 – pre sieť kde je PC2, na smerovač dajte prvú použiteľnú adresu
  • a. SLAAC
    • Najjednoduchšia forma získania sieťovej adresy. Smerovač po zapnutí ipv6 smerovania a nakonfigurovaní globálnej unicastovej adresy na rozhraní začne posielať tzv. RA, v ktorom je informácia o sieťovej adrese, dĺžke prefixu a bráne. Koncová stanica sa nakonfiguruje sama po prijatí RA – k prijatej sieťovej adrese si sama dogeneruje host časť adresy (EUI-64 alebo random generátorom). Príkazom ipv6 nd prefix default no-autoconfig vypíname mechanizmus SLAAC.
  • b. Stateless DHCP
    • Koncové zariadenie si IPv6 adresu skonfiguruje na základe RA, ale o zvyšné sieťové nastavenia (DNS, Domain-name …) požiada DHCP server. Smerovač to oznámi koncovému používateľovi nastavením tzv. other-config-flag v RA.
R1(config)#ipv6 unicast-routing
R1(config)#ipv6 dhcp pool IPV6-stateless
R1(config-dhcpv6)#dns-server 2001:db8:0:1::1
R1(config-dhcpv6)#domain-name cnl.sk
R1(config)#int fa0/0
R1(config-if)#ipv6 add 2001:db8:0:1::1/64
R1(config-if)#ipv6 dhcp server IPV6-stateless
R1(config-if)#ipv6 nd other-config-flag
    • c. Stateful DHCP
      • Koncové zariadenia ignorujú informáciu prijatú v RA a všetky sieťové informácie si vyžiadajú od DHCP servera. Túto skutočnosť im oznamuje smerovač v RA nastavením tzv. managed-config-flag.
R1(config)#ipv6 unicast-routing
R1(config)#ipv6 dhcp pool IPV6-stateful
R1(config-dhcpv6)#address prefix 2001:db8:0:1::/64 lifetime infinite infinite
R1(config-dhcpv6)#dns-server 2001:db8:0:1::1
R1(config-dhcpv6)#domain-name cnl.sk
R1(config)#int fa0/0
R1(config-if)#ipv6 add 2001:db8:0:1::1/64
R1(config-if)#ipv6 dhcp server IPV6-stateful
R1(config-if)#ipv6 nd managed-config-flag

 

Z pohľadu koncového zariadenie je z príkazového riadka potrebné zadať príkazy:

C:\>ipconfig /release6
C:\>ipconfig /renew6

 

  1. HSRP:

HSRP umožňuje redundanciu brány tým, že smerovače patriace do jednej skupiny zdieľajú virtuálnu IP a MAC adresu.

Topológia:

R1(config)#int fa0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#standby 1 ip 192.168.1.254
R1(config-if)#standby 1 preempt
R1(config-if)#standby 1 priority 101

 

R1#show standby [brief]

 

Pozn.: Priorita určuje, ktorý smerovač prevezme na seba rolu aktívneho smerovača. Štandardná hodnota je 100. Vyššia hodnota vyhráva.

Pozn.: Preempt zabezpečí, že budeme bojovať o rolu aktívneho smerovača. Inak je rola daná „doživotne“.

Ukážka konfigurácie DHCP s použitím smerovača MikroTik

Na nasledujúcej topológii realizujte konfiguráciu DHCP pre IPv4 a zabezpečte komunikáciu medzi zariadeniami zo vzdialených sieti.

Topológia:

1. Konfigurácia IP adries na rozhrania:

Vzhľadom k topológii v prvom rade pridajte IP adresy na rozhrania smerovačov. Na spojení medzi smerovacom 1 a smerovacom 2 pridajte prvú a druhú použiteľnú adresu. Ako bránu pre lokálnu sieť 10 a 20 použite poslednú použiteľnú adresu.

2. Vytvorenie POOL-ov:

Pre vymedzenie prideľovaných adries vytvorte dva POOL-y s názvom LAN10 a LAN20. POOL LAN10 obsahuje adresný rozsah 192.168.10.1-192.168.10.10 a LAN20 adresný rozsah 192.168.20.1-192.168.20.10. Dané POOL-y vytvorte na smerovači 1.

/ip pool add name=LAN10 ranges=192.168.10.1-192.168.10.10 # vytvorenie POOL-u

/ip pool add name=LAN20 ranges=192.168.20.1-192.168.20.10 # vytvorenie POOL-u

3. Konfigurácia DHCP:

Smerovač 1 nakonfigurujte ako DHCP server s názvom dhcpLAN10, ktorý bude automaticky prideľovať sieťové nastavenia pre lokálnu sieť 10.

/ip dhcp-server add interface=ether2 name=dhcpLAN10 address-pool=LAN10 # vytvorenie DHCP servera na rozhranie a pridelenie POOLu

/ip dhcp-server set dhcpLAN10 disabled=no # zapnutie vytvoreného dhcp servera

/ip dhcp-server network add address=192.168.10.0/24 gateway=192.168.10.254 # pridanie siete, ktorej chceme prideľovať sieťové nastavenia od DHCP servera

/ip dhcp-server add interface=ether1 relay=192.168.20.254 address-pool=LAN20 name=DHCP-relay disabled=no # pridanie relay adresy na rozhranie a priradenie POOLu

/ip dhcp-client set interface=ether2 disabled=no # nastavenie DHCP klienta

/ip route add gateway=192.168.30.2 # pridanie brány smerom k sieti 20

4. Konfigurácia relay agenta:

Smerovač 2 je potrebné nakonfigurovať ako relay agenta, ktorý bude unicast správou posielať DHCP požiadavku zo siete LAN20 na DHCP server. Následne zariadeniam zo sieti 20 budú pridelené sieťové nastavenia z POOL-u LAN20.

/ip dhcp-relay add name=relayLAN20 interface=ether2 dhcp-server=192.168.30.1 local-address=192.168.20.254 disabled=no # vytvorenie relay agenta

Poznámka

Vzhľadom k využívaniu MikroTik smerovačov, tieto smerovače nedisponujú možnosťou vymedzenia IP adresy, ktorá nemôže byť pridelená. Pre tento dôvod môžeme vytvoriť POOL-y obsahujúce nevyhovujúce adresy. Následne ak tieto POOL-y nepridelíme žiadnemu DHCP serveru, tieto adresy nebudú nikdy pridelené.

Konfigurácia pomocou grafického rozhrania

Pre konfiguráciu DHCP je taktiež možné využiť grafické rozhranie. Konkrétne v grafickom rozhraní WinBox existujú štyri záložky v podmenu IP, ktoré sú potrebné pre konfiguráciu DHCP. V prvom rade pre vytvorenie POOL-u adries je potrebné na smerovači 1 prejsť do záložky Pool. Následne je potrebné vytvoriť DHCP server na smerovači 1 so všetkými potrebnými nastaveniami. Konkrétne v tejto záložke je možné vytvoriť samotný server so zvoleným názvom, určenie rozhrania ktorým smerom existuje sieť ktorej budú prideľované sieťové nastavenia, nastavenie IP adresy smerom k relay agentovi a pridelenie POOLu. Na obrázkoch 1, 2, 3, 4, 5 môžeme vidieť jednotlivé časti tejto konfigurácie. Konfigurácia relay agenta je vykonaná na smerovači 2.

Obr. 1: Vytvorenie POOL-u adries
Obr. 2: Nastavenie DHCP servera
Obr. 3: Pridanie IP adries sieti
Obr. 4: Pridanie DHCP klienta na určité rozhranie
Obr. 5: Vytvorenie Relay agenta

Ukážka konfigurácie protokolu VRRP s použitím smerovača MikroTik

Na nasledujúcej topológii je nakonfigurujte protokol VRRP. Tento protokol zabezpečuje redundanciu brány tým, že smerovače patriace do jednej skupiny zdieľajú virtuálnu IP a MAC adresu. V podstate je tento protokol ekvivalentom Cisco protokolu HSRP. Podľa topológie je potrebné nastaviť IP adresy na rozhrania smerovačov a zabezpečiť aby bol smerovač 1 hlavným smerovačom. V prípade tejto topológie je nastavené rovnaké vrid pre oba smerovače. Vrid je identifikátor VRRP protokolu v rámci siete. Každý virtuálny smerovač musí mať tento identifikátor unikátny. Ak chceme určiť, ktorý smerovač má byť hlavným, nastavíme mu najvyššiu možnú prioritu, v prípade tejto topológie je to 254. Následne je potrebné konfiguráciu overiť pomocou nástroja ping na virtuálnu IP adresu za rôzneho stavu pripojenia fyzických káblov.

Topológia:

Príklad konfigurácie:

Smerovač 1

/interface vrrp add interface=ether1 vrid=1 priority=254 # vytvorenie vrrp a nastavenie priority

/ip address add address=192.168.1.254/24 interface=vrrp1 # pridanie IP adresy na vrrp

/interface vrrp print detail # týmto príkazom je možné skontrolovať aktuálne vlastnosti vytvoreného vrrp

Smerovač 2

/interface vrrp add interface=ether1 vrid=1 # vytvorenie vrrp

/ip address add address=192.168.1.254/24 interface=vrrp1 # pridanie IP adresy na vrrp

Poznámka

Priorita v protokole VRRP určuje, ktorý smerovač bude hlavný. Vyššie číslo znamená vyššiu prioritu. Hodnota 255 je vyhradená pre smerovač, ktorý vlastní VR IP a hodnota 0 je vyhradená pre hlavný smerovač.