Úvod PS Cvičenie 8: Statické smerovanie

Cvičenie 8: Statické smerovanie

3318
0

Topológia:

Všetkým zariadeniam prideľte IP adresy z podsietí podľa obr. PC dajte poslednú použiteľnú adresu z danej podsiete a smerovačom prvú. Na prepoji medzi smerovačmi prideľte rozhraniu R2 prvú a R4 druhú adresu.

  • Pre IPv6 použite adresy:
    • 2001:db8:0:2::/64 – pre sieť kde je PC2, na smerovač dajte prvú použiteľnú a na počítač druhú použiteľnú adresu
    • 2001:db8:0:24::/64 – na prepoji, na R2 dajte druhú a na R4 prvú použiteľnú adresu
    • 2001:db8:0:4::/64 – pre sieť kde je PC4, na smerovač dajte prvú a na počítač druhú použiteľnú adresu
  1. Statické smerovanie:

Smerovač pozná len priamo pripojené siete. Ak chce smerovať dáta do vzdialených sieti, tak je potrebné vložiť záznam o týchto sieťach do smerovacej tabuľky. Statická cesta obsahuje sieťovú adresu vzdialenej siete, masku danej vzdialenej siete a smer kadiaľ sa k danej vzdialenej sieti dostaneme (určíme výstupne rozhranie na našom smerovači – možné využiť ale len pri point-to-point prepojoch, alebo next-hop IP adresu – teda adresu susedného smerovača, cez ktorého sa dostaneme k danej sieti). Statické smerovanie konfigurujeme príkazom ip/ipv6 route. Výstupné rozhranie a next-hop IP adresu vieme kombinovať.

R2(config)#ip route 192.168.4.0 255.255.255.0 serial0/0/1

alebo

R2(config)#ip route 192.168.4.0 255.255.255.0 192.168.24.2

alebo

R2(config)#ip route 192.168.4.0 255.255.255.0 192.168.24.2 se0/0/1

 

Poznámka:
V prípade konfigurácie IPv6 je potrebné zapnúť smerovanie pre IPv6 príkazom ipv6 unicast-routing v globálnom konfiguračnom móde.

 

R2(config)#ipv6 route 2001:db8:0:4::/64 serial0/0/1
R2(config)#ipv6 route 2001:db8:0:4::/64 2001:db8:0:24::/64

Ako next-hop ip adresa môže byť použitá aj link-local adresa. V tomto prípade je ale potrebné uviesť aj výstupné rozhranie.

R2(config)#ipv6 route 2001:db8:0:4::/64 serial0/0/1 fe80::4

 

Pozn.:
Floating static route nám umožňuje vložiť smerovaciu informáciu do smerovacej tabuľky s vyššou administratívnou vzdialenosťou. V prípade ak primárna cesta vypadne zo smerovacej tabuľky, tak automaticky sa do nej zaradí nakonfigurovaná plávajúca statická cesta.

R2(config)#ip route 192.168.4.0 255.255.255.0 serial0/0/1 150

Floating static route pre IPv6:

R2(config)#ipv6 route 2001:db8:0:4::/64 serial0/0/1 150
  1. Loopback rozhranie:

Loopback rozhranie slúži na testovacie účely a umožňuje simulovať lokálnu sieť (je možné testovať konektivitu pomocou tohto rozhrania). Ide o virtuálne rozhranie, ktoré je vždy aktívne. Loopback vytvoríme príkazom interface loopback č. a pridelíme mu IP adresu.

R2(config)#interface loopback 1
R2(config-if)#ip address 1.1.1.1 255.255.255.255

 

  1. Predvolená cesta – Default route

Default route je záznam, ktorý pokrýva všetky siete – konfiguruje sa zväčša na smerovači, ktorý je na okraji siete. Platia všetky predchádzajúce možnosti konfigurácie.

R3(config)#ip route 0.0.0.0 0.0.0.0 se0/1/0
R3(config)#ipv6 route ::/0 se0/1/0

Ukážka konfigurácie statického smerovania s použitím smerovača MikroTik

Na nasledujúcej topológii realizujte konfiguráciu statického smerovania. Je potrebné zabezpečiť Komunikáciu medzi PC-1 a PC-2, ktoré patria do rozdielnych lokálnych sieti. Zároveň je potrebné poskytnúť obom koncovým zariadeniam prístup do vonkajšej siete Internet.

Topológia:

1. Nastavenie IP adries na koncové zariadenia:

Podľa uvedenej topológie nastavte na koncové zariadenia IP adresu a bránu z daných podsietí. Na koncové zariadenia použite prvú použiteľnú adresu z rozsahu a ako bránu poslednú použiteľnú adresu.

2. Konfigurácia IP adries na rozhrania:

Nastavte IP adresy na rozhrania smerovačov podľa uvedenej topológie. Na spojení medzi smerovačom 1 a 2 použite prvú a druhú použiteľnú adresu z rozsahu. Na smerovači 1 nezabudnite pridať IP adresu, smerom k vonkajšej sieti Internet podľa príslušnej topológie.

/ip address add address=[IP adresa]/prefix interface=[rozhranie] # pridanie IP adresy na rozhranie

3. Konfigurácia statického smerovania:

Smerovače nachádzajúce sa v uvedenej topológii poznajú len priamo pripojené siete. Ak chcú smerovať dáta do vzdialených sieti, je potrebné vložiť záznam o týchto sieťach do smerovacej tabuľky. Časť príkazu dst-address vyjadruje vzdialenú sieť a časť gateway, ktorým smerom sa neznáma sieť nachádza. V našom prípade je to IP adresa na smerovači 2 rozhraní e1. Ďalej pridajte v podmenu /ip route bránu pre vzdialenú
sieť Internet, ako prvú použiteľnú adresu podľa rozsahu siete. Na smerovači 2 taktiež pridajte bránu na vzdialenú sieť smerovača 1. Konfigurácia cesty do vzdialenej siete nie je potrebná, pretože komunikácia bude dosiahnutá vďaka predvolenej ceste. Vytvorenú konfiguráciu je možné overiť pingom z PC-1 na PC-2 a do vzdialenej siete Internet.

Smerovač 1

/ip route # prejdenie do podmenu

add gateway=10.1.1.1 # pridanie brány smerom k vonkajšej sieti

add dst-address=192.168.2.0/24 gateway=172.16.1.2 # pridanie záznamu o vzdialenej sieti

Smerovač 2

/ip route add gateway=172.16.1.1 # nastavenie smeru pre predvolenú cestu